Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.4

Bug #2728 Linebreaks not being read using getScript()
Submitted: 2004-11-10 09:41 UTC
From: matthew at de-construct dot com Assigned: damian
Status: Closed Package: Net_Sieve
PHP Version: 4.3.2 OS: Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 7 - 1 = ?

 
 [2004-11-10 09:41 UTC] matthew at de-construct dot com
Description: ------------ in version 1.0.1 of Net_Sieve, i'm using getScript() to retrieve a specific sieve script from the mailserver. whilst it returns the contents of the script accurately, the content of the actual body of items enclosed in quotation marks (see sieve script below) is returned without linebreaks. Sieve Script: require "vacation"; vacation :days 7 :addresses ["matthew@de-construct.com"] :subject "This is a test" "I'm on my holiday! sadfafs"; Reproduce code: --------------- $script = $sieve->getScript('vacation.msg'); print $script; Expected result: ---------------- expect to see the script as it is in the sieve script file (see description) Actual result: -------------- require "vacation"; vacation :days 7 :addresses ["matthew@de-construct.com"] :subject "This is a test" "I'm on my holiday! sadfafs"; (note the lack of linebreak after 'holiday!'

Comments

 [2004-12-05 18:01 UTC] damian
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/Net_Sieve