Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 3.4.2

Bug #16698 Notice in JavaScript Tokenizer
Submitted: 2009-10-13 14:32 UTC
From: sebastian Assigned: squiz
Status: Closed Package: PHP_CodeSniffer (version 1.2.0)
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  


 [2009-10-13 14:32 UTC] sebastian (Sebastian Bergmann)
Description: ------------ Notice in JavaScript Tokenizer. Expected result: ---------------- No notice. Actual result: -------------- Notice: Undefined offset: 3454 in /usr/share/php/PHP/CodeSniffer/Tokenizers/JS.php on line 669 Call Stack: 0.0042 103656 1. {main}() /usr/bin/phpcs:0 0.0410 2044080 2. PHP_CodeSniffer_CLI->process() /usr/bin/phpcs:30 0.0418 2049680 3. PHP_CodeSniffer->process() /usr/share/php/PHP/CodeSniffer/CLI.php:389 0.0853 2714760 4. PHP_CodeSniffer->processFiles() /usr/share/php/PHP/CodeSniffer.php:341 68.0600 15326224 5. PHP_CodeSniffer->processFile() /usr/share/php/PHP/CodeSniffer.php:690 68.0606 15329632 6. PHP_CodeSniffer_File->start() /usr/share/php/PHP/CodeSniffer.php:762 68.0606 15329760 7. PHP_CodeSniffer_File->_parse() /usr/share/php/PHP/CodeSniffer/File.php:362 68.0616 15343000 8. PHP_CodeSniffer_File::tokenizeString() /usr/share/php/PHP/CodeSniffer/File.php:503 68.0616 15343136 9. PHP_CodeSniffer_Tokenizers_JS->tokenizeString() /usr/share/php/PHP/CodeSniffer/File.php:740

Comments

 [2009-10-13 14:36 UTC] squiz (Greg Sherwood)
I don't think I'll be able to track down the cause without some sample code. Do you have some you can submit and have you tried the SVN version on the file (I remember making some changes to the tokenizer)?
 [2009-10-13 14:36 UTC] squiz (Greg Sherwood)
-Status: Open +Status: Feedback -Assigned To: +Assigned To: squiz
 [2009-10-13 18:46 UTC] sebastian (Sebastian Bergmann)
I cannot track this down to a small, reproducing example. All I can is that I am running into this issue with the Zend standard when applied to TikiWiki.
 [2009-10-22 04:56 UTC] squiz (Greg Sherwood)
-Status: Feedback +Status: Assigned
 [2009-10-22 05:20 UTC] squiz (Greg Sherwood)
Thanks for that info. I found the file: lib/swfobject/swfobject.js Will take a look.
 [2009-10-22 06:52 UTC] squiz (Greg Sherwood)
-Status: Assigned +Status: Closed
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.