Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 3.4.2

Request #14874 Allow GIT: in @version
Submitted: 2008-10-25 19:40 UTC
From: till Assigned: squiz
Status: Closed Package: PHP_CodeSniffer (version 1.1.0)
PHP Version: 5.2.6 OS:
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 27 + 22 = ?

 
 [2008-10-25 19:40 UTC] till (Till Klampaeckel)
Description: ------------ Invalid version "GIT:" in file comment; consider "CVS:<cvs_id>" or "SVN: <svn_id>" instead

Comments

 [2008-10-26 23:44 UTC] squiz (Greg Sherwood)
This would mean changing the PEAR standard to assume GIT is used, but I believe only CVS and SVN (for PEAR2) are currently supported. Might want to try your own coding standard and override the processVersion() method.
 [2011-10-08 02:39 UTC] boen_robot (Vasil Rangelov)
"assume GIT is used"? Do you mean "allow Git"? I see the comments in this bug report are old, so probably this simply hasn't been brought up since, so let me do that... PEAR2 now uses Git, given the fact that all existing PEAR2 packages are using Git only and hosted on GitHub. It's about time for Git to be allowed.
 [2011-11-01 04:11 UTC] squiz (Greg Sherwood)
-Status: No Feedback +Status: Closed
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.