Comments for "Services_Atlassian_Crowd"

» Submit Your Comment
Comments are only accepted during the "Proposal" phase. This proposal is currently in the "Finished" phase.
» Comments
  • David Jean Louis  [2008-07-08 13:27 UTC]

    Hey Luca,

    Never heard of Crowd so I can't "judge" the package, here are some general remarks nonetheless:
    * I would not make the 3 class variables private, it makes sub-classing difficult, "protected" seems better to me;
    * I think some repeated parts of the code (especially in the 3 last methods) could be put in common (using a protected method or using the __call() magic method...).

    Looks good and well documented and tested otherwise.
  • Till Klampaeckel  [2008-07-08 15:39 UTC]

    Hey Luca - looks pretty good, though I agree with David on what he mentioned.

    One thing though - I think other Atlassian products offer APIs (e.g. Jira) as well. Therefor, I'd propose Services_Atlassian_Crowd.