Comments for "Crypt_Blowfish"

» Submit Your Comment
Comments are only accepted during the "Proposal" phase. This proposal is currently in the "Finished" phase.
» Comments
  • Alan Knowles  [2005-02-08 12:19 UTC]

    Just a few points
    * defining 'N' should not be done all defines should be prefixed CRYPT_BLOWFISH_*
    * private methods should be prefixed with _

    * It may be worth using more descriptive method and property names than P,N etc.

    * I'm not sure if loading the default crypt keys from a file might be better (removes alot of noise from the code)

    * removing @ wrappers is prefered practice (you will get bug reports from people complaing about it ;)
  • Matthew Fonda  [2005-02-08 12:41 UTC]

    All constants are now prefixed with CRYPT_BLOWFISH_* and private methods are now prefixed with _

    The @ wrapper is needed on ord, because depending on the length of the string, the offset used with ord may not exist during the last cycle through the loop. Rather than using a bunch of if statements to check if it does or not, I thought using @ to suppress warnings would work better.
  • Matthew Fonda  [2005-02-08 16:22 UTC]

    Alright, @ wrappers have been removed, and the default key is not loaded from a file.