Comments for "Styled"

» Submit Your Comment
Comments are only accepted during the "Proposal" phase. This proposal is currently in the "Finished" phase.
» Comments
  • Alan Knowles  [2004-12-15 09:44 UTC]

    * there's a few minor tab/space issues in the files
    * one file has require_once 'Style....php', rather than Gtk/Style....

    Following the package name being part of the class/filename the classes should really be
    Gtk_StyleObjects_HAdjustment etc.

    I think Gtk_Styled_HAdjustment etc. is probably a better name (and a little shorter)
  • Michael Wallner  [2004-12-28 09:04 UTC]

    I've harldy any experience with PHP_GTK, but the code looks reasonable, the methods are well documented and there's a descriptive example.

    The only thing I would suggest is using an array for the constructor, because remembering "names" (i.e. array keys) is easier than remembering the order of the parameters.
  • Scott Mattocks  [2004-12-28 13:07 UTC]

    Thanks Michael. I completely agree that an array would be easier here but I am trying to match the API of GtkAdjustment ( For developers who are used to working with PHP-GTK, the six individual parameters will seem more "natural".