Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.4

Bug #998 parseString incorrectly reads attribute values with colons in
Submitted: 2004-03-12 06:38 UTC
From: matt at sensibleerection dot com Assigned: thesaur
Status: Closed Package: HTML_CSS
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 15 + 47 = ?

 
 [2004-03-12 06:38 UTC] matt at sensibleerection dot com
Description: ------------ When parsing in some CSS like: .sec { display: none; } .month:before { content: "-"; } .year:before { content: "-"; } .min:before { content: ":"; } .sec:before { content: ":"; } the resulting array snippit will be: [.sec] => Array ( [display] => none ) [.month:before] => Array ( [content] => "-" ) [.year:before] => Array ( [content] => "-" ) [.min:before] => Array ( [content] => " ) [.sec:before] => Array ( [content] => " ) CSS.php lines 481 and 494 (in 0.3.1) use an explode on ":", which excludes attribute values from being able to include colons.

Comments

 [2004-03-24 22:08 UTC] thesaur at php dot net
I have fixed this in CVS. It will be included in the next release. Thank you for alerting us to this issue! If the patch does not resolve it, please let us know.