Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.13

Bug #933 CMD Usability Patch
Submitted: 2004-03-02 19:45 UTC
From: techtonik at tut dot by Assigned: cellog
Status: Closed Package: PEAR
PHP Version: 4CVS-2004-03-02 (stable) OS: Windows
Roadmaps: (Not assigned)    
Subscription  


 [2004-03-02 19:45 UTC] techtonik at tut dot by
Description: ------------ By default PEAR requires that users set up register_argc_argv=On so they can use it from command line, but this is inconvenient in many cases there PEAR is used only on web-server and updated from cmd. So it would be better to include register_argc_argv=On to pear.bat instead. As it said in php.ini ; If you don't use these variables, you ; should turn it off for increased performance. register_argc_argv = Off Reproduce code: --------------- 67c67 < "%PHP_PEAR_PHP_BIN%" -C -d output_buffering=1 -d include_path="%PHP_PEAR_INSTALL_DIR%" -f "%PHP_PEAR_INSTALL_DIR%\pearcmd.php" -- %1 %2 %3 %4 %5 %6 %7 %8 %9 --- > "%PHP_PEAR_PHP_BIN%" -C -d output_buffering=1 -d register_argc_argv=On -d include_path="%PHP_PEAR_INSTALL_DIR%" -f "%PHP_PEAR_INSTALL_DIR%\pearcmd.php" -- %1 %2 %3 %4 %5 %6 %7 %8 %9

Comments

 [2004-03-14 08:02 UTC] dufuz
If looked at the latest posts on the core ML http://news.php.net/group.php?group=php.pear.core then this issue seems to have been fixed. some please verify that and if so close this bug :)
 [2004-03-14 13:01 UTC] pajoye
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.