Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.9

Bug #8794 upgrade-all including Auth fails with fatal error
Submitted: 2006-09-26 19:49 UTC
From: justinpatrin Assigned: cellog
Status: Closed Package: PEAR (version 1.4.11)
PHP Version: 5.1.4 OS:
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 15 - 14 = ?

 
 [2006-09-26 19:49 UTC] justinpatrin (Justin Patrin)
Description: ------------ Upgrading Auth from 1.3.0 (stable) to 1.4.0RC3 (beta) with upgrade-all caused PEAR to fail with below error consistently. Calling "pear upgrade Auth" worked fine and subsequent upgrade-all upgraded the rest of my packages without problems. Test script: --------------- pear list-upgrades PEAR.PHP.NET AVAILABLE UPGRADES (ALPHA, BETA, STABLE): ====================================================== CHANNEL PACKAGE LOCAL REMOTE SIZE pear.php.net Auth 1.3.0 (stable) 1.4.0RC3 (beta) 52kB pear.php.net Console_Table 1.0.4 (stable) 1.0.5 (stable) 6.9kB pear.php.net DB_DataObject_FormBuilder 1.0.0RC4 (beta) 1.0.0RC5 (beta) 62kB pear.php.net HTML_Progress2 2.0.1 (stable) 2.1.0 (stable) 366kB pear.php.net HTML_Table 1.7.2 (stable) 1.7.3 (stable) 13.8kB pear.php.net HTML_Template_IT 1.1.4 (stable) 1.2.1 (stable) 22kB pear.php.net Mail 1.1.10 (stable) 1.1.13 (stable) 17.2kB pear.php.net MDB2 2.2.0 (stable) 2.2.2 (stable) 98kB pear.php.net MDB2_Driver_mysql 1.2.0 (stable) 1.2.2 (stable) 26kB pear.php.net MDB2_Driver_oci8 1.0.0 (stable) 1.0.2 (stable) 26kB pear.php.net PEAR_PackageFileManager 1.6.0b2 (beta) 1.6.0b4 (beta) 83kB pear.php.net PHP_CompatInfo 1.1.2 (stable) 1.3.2 (stable) 53kB pear.php.net Spreadsheet_Excel_Writer 0.9.0 (beta) 0.9.1 (beta) 54kB pear.php.net Structures_DataGrid_DataSource_DBQuery 0.1.2 (beta) 0.1.3 (beta) 3.9kB pear.php.net Structures_DataGrid_DataSource_DBTable 0.1.3 (beta) 0.1.4 (beta) 3.3kB pear.php.net Structures_DataGrid_DataSource_MDB2 0.1.1 (beta) 0.1.2 (beta) 4.0kB pear.php.net Structures_DataGrid_DataSource_XML 0.1.0 (beta) 0.1.1 (beta) 3.0kB pear.php.net Structures_DataGrid_Renderer_CSV 0.1.1 (beta) 0.1.2 (beta) 3.1kB pear.php.net Structures_DataGrid_Renderer_HTMLTable 0.1.0 (beta) 0.1.1 (beta) 5.2kB pear.php.net Structures_DataGrid_Renderer_XML 0.1.0 (beta) 0.1.1 (beta) 2.8kB pear.php.net XML_RSS 0.9.9 (beta) 0.9.10 (beta) 5.7kB pear upgrade-all Actual result: -------------- Fatal error: Call to undefined method PEAR_PackageFile_v1::getProvidesExtension() in /usr/lib/php/PEAR/Downloader/Package.php on line 963 Call Stack: 0.0017 1. {main}() /usr/lib/php/pearcmd.php:0 0.0891 2. PEAR_Command_Common->run() /usr/lib/php/pearcmd.php:304 0.0891 3. PEAR_Command_Install->doInstall() /usr/lib/php/PEAR/Command/Common.php:273 0.3173 4. PEAR_Downloader->download() /usr/lib/php/PEAR/Command/Install.php:423 1.5710 5. PEAR_Downloader->analyzeDependencies() /usr/lib/php/PEAR/Downloader.php:388 1.6552 6. PEAR_Dependency2->validatePackageDependency() /usr/lib/php/PEAR/Downloader.php:539 1.6552 7. PEAR_Dependency2->_validatePackageDownload() /usr/lib/php/PEAR/Dependency2.php:615 1.6573 8. PEAR_Downloader_Package->isExtension() /usr/lib/php/PEAR/Dependency2.php:645

Comments

 [2006-10-12 21:24 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2007-01-02 21:26 UTC] chuck dot hoffman at t8design dot com (Chuck Hoffman)
How can I get this fix? I am having the same issue.
 [2007-01-02 22:08 UTC] justinpatrin (Justin Patrin)
Upgrade to the newest version of PEAR (1.5.0RC2). It is an RC and so is marked beta currently. I suggest you simply wait for a stable release and do "pear upgrade Auth" and then do "pear upgrade-all".