Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.13

Bug #7582 pecl command is invoked with php option -n disabling needed extensions
Submitted: 2006-05-08 19:49 UTC
From: toni dot viemero at iki dot fi Assigned:
Status: Bogus Package: PEAR (version 1.4.9)
PHP Version: 5.1.2 OS: FreeBSD 6.1-RELEASE
Roadmaps: (Not assigned)    
Subscription  


 [2006-05-08 19:49 UTC] toni dot viemero at iki dot fi (Toni Viemero)
Description: ------------ The "pecl" command invokes PHP with option -n, disabling reading of php.ini and needed extensions for "pecl" to work. Since FreeBSD ports system builds PHP extensions as shared extensions and one of them is pcre, which is needed by pecl. Does pecl really need to disable the reading of php.ini or do I file a report against FreeBSD PHP package? "pear" command works fine, since it doesn't use the -n option when invoking pearcmd.php PS. Your PHP version list is outdated at the bug reporter, I'm using PHP 5.1.4 Test script: --------------- Invoke "pecl" from command line Actual result: -------------- Fatal error: Call to undefined function preg_match() in /usr/local/share/pear/PEAR/Frontend/CLI.php on line 70

Comments

 [2006-05-09 01:52 UTC] cellog (Greg Beaver)
Thank you for taking the time to write to us, but this is not a bug. if you have preg, zlib, or xml in php.ini as a shared extension, then you must run: pear <command> pecl/packagename instead of pecl <command> packagename The results are the same. The entire purpose of the pecl command is to remove all extensions from memory so that you can overwrite them (a file locking issue)