Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #7464 run-scripts causes notices
Submitted: 2006-04-23 21:49 UTC
From: pascal at tweakers dot net Assigned: cellog
Status: Closed Package: PEAR (version 1.4.9)
PHP Version: 4.4.2 OS: Fedora 3
Roadmaps: (Not assigned)    
Subscription  


 [2006-04-23 21:49 UTC] pascal at tweakers dot net (Pascal)
Description: ------------ [admin@www tmp]$ pear run-scripts pear Notice: Undefined index: scripts/pear.bat in PEAR/PackageFile/v2.php on line 606 Notice: Undefined index: scripts/peardev.bat in PEAR/PackageFile/v2.php on line 606 Notice: Undefined index: scripts/pecl.bat in PEAR/PackageFile/v2.php on line 606 Install scripts complete *** glibc detected *** corrupted double-linked list: 0x09d536e8 *** When execution a PEAR option I get this error. Even rebuilding PHP will fail cause of this error. I don't know what happened but getting this after doing an upgrade-all.

Comments

 [2006-04-25 02:36 UTC] cellog (Greg Beaver)
the glibc thing is a bug in PHP, not in PEAR. The rest is valid, so changing the subject line
 [2006-04-25 02:54 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.