Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #7368 undefined function: getprovidesextension()
Submitted: 2006-04-11 15:56 UTC
From: toggg Assigned: cellog
Status: Closed Package: PEAR (version CVS)
PHP Version: 4.3.11 OS: fc3
Roadmaps: (Not assigned)    
Subscription  


 [2006-04-11 15:56 UTC] toggg (bertrand Gugger)
Description: ------------ # pear -V PEAR Version: 1.5.0a1 PHP Version: 4.3.11 Zend Engine Version: 1.3.0 Running on: Linux ancilla.toggg.net 2.6.12-1.1381_FC3 #1 Fri Oct 21 03:46:55 EDT 2005 i686 # pear upgrade Console_Getargs Console_Table HTML_AJAX-alpha HTML_QuickForm_advmultiselect MDB_QueryTool PEAR_RemoteInstaller-alpha Services_Weather Text_Wiki_Mediawiki-alpha Did not download optional dependencies: pecl/ssh2, use --alldeps to download automatically pear/PEAR_RemoteInstaller requires PHP (version >= 5.0.0), installed version is 4.3.11 PHP Fatal error: Call to undefined function: getprovidesextension() in /usr/share/pear/PEAR/Downloader/Package.php on line 969 Fatal error: Call to undefined function: getprovidesextension() in /usr/share/pear/PEAR/Downloader/Package.php on line 969 I tried to upgrade partially to narrow which package was doing it: # pear upgrade Console_Getargs Console_Table HTML_AJAX-alpha HTML_QuickForm_advmultiselect MDB_QueryTool .... upgrade ok: channel://pear.php.net/Console_Table-1.0.4 upgrade ok: channel://pear.php.net/MDB_QueryTool-1.1.0 upgrade ok: channel://pear.php.net/HTML_QuickForm_advmultiselect-1.2.0 upgrade ok: channel://pear.php.net/HTML_AJAX-0.4.0 upgrade ok: channel://pear.php.net/Console_Getargs-1.3.1 # pear upgrade Text_Wiki_Mediawiki-alpha .... upgrade ok: channel://pear.php.net/Text_Wiki_Mediawiki-0.1.0 But then the error does not come back: # pear upgrade PEAR_RemoteInstaller-alpha Services_Weather Did not download optional dependencies: pecl/ssh2, use --alldeps to download automatically pear/PEAR_RemoteInstaller requires PHP (version >= 5.0.0), installed version is 4.3.11 pear/PEAR_RemoteInstaller can optionally use package "pecl/ssh2" pear/Services_Weather dependency package "pear/Net_FTP" installed version 1.3.2 is not the recommended version 1.3.1, but may be compatible, use --force to install pear/Services_Weather dependency package "pear/Cache" installed version 1.5.5RC4 is not the recommended version 1.5.4, but may be compatible, use --force to install pear/Services_Weather dependency package "pear/SOAP" installed version 0.9.3 is not the recommended version 0.9.1, but may be compatible, use --force to installNo valid packages found upgrade failed which is perfectly valid...

Comments

 [2006-04-12 21:44 UTC] cellog (Greg Beaver)
Thank you for taking the time to report a problem with the package. This problem may have been already fixed by a previous change that is in the CVS of the package. Please log into CVS with: cvs -d :pserver:cvsread@cvs.php.net:/repository login and check out the CVS repository of this package and upgrade cvs -d :pserver:cvsread@cvs.php.net:/repository co pear-core pear upgrade pear-core/package2.xml or pear upgrade pear-core/package.xml If you are able to reproduce the bug with the latest CVS, please change the status back to "Open". Again, thank you for your continued support of PEAR.
 [2006-04-12 22:45 UTC] toggg (bertrand Gugger)
It's quite difficult to reproduce. As I tried to narrow it , I destroyed the case. Not sure it's possible for me to set it back. I admit the whole looks strange. Could that be related to some v1-v2 sequences in deps ?
 [2006-04-12 22:48 UTC] toggg (bertrand Gugger)
I set it back open, do what you want with it.
 [2006-04-12 23:01 UTC] cellog (Greg Beaver)
this was caused by this sequence: PEAR_RemoteInstaller depends on pecl/ssh2 with this tag: <package> <name>ssh2</name> <channel>pecl.php.net</channel> <providesextension>ssh2</providesextension> </package> This prompts the installer to iterate over each of the detected packages, to check if any is the extension ssh2. Since one of them uses a package.xml 1.0, it causes the fatal error. Hence the patch did indeed fix this bug. :)
 [2006-04-12 23:18 UTC] toggg (bertrand Gugger)
OK, I understand the case. Sorry , there was a time mismatch and the bug update came before the cvs update. Insanes often fall in traps :)