Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.8.0

Bug #7367 Marker for top Y-value cut
Submitted: 2006-04-11 15:16 UTC
From: jorgen at zeklabs dot com Assigned: nosey
Status: Closed Package: Image_Graph (version 0.7.2)
PHP Version: 5.1.2 OS: Windows XP
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 47 + 17 = ?

 
 [2006-04-11 15:16 UTC] jorgen at zeklabs dot com (J├Ârgen Bitzekis)
Description: ------------ When using markers with line graphs the marker for the Y-value is cut (doesn't show completely). I have tried using margins and such but have not found a solution. Test script: --------------- You can find the error displayed here: http://pear.veggerby.dk/samples/show/id/misc05/ Expected result: ---------------- You will see that the marker for September (72mm) doesn't show completely.

Comments

 [2006-04-11 16:33 UTC] nosey (Jesper Veggerby)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. This is (or was!) actually a bug related to the use of clipping to avoid "out-of-area" graphs when using, fx forceMinimum() with a value larger than the actual minimum. Clipping was done when drawing the graph and _also_ when drawing the markers. The markers have now been moved outside the clipping section, and since there are some other logic that handles completely-"out-of-area" markers there //should// be no problems here :D The "was!" is because I fixed this and comitted to CVS yesterday :) /nosey
 [2006-04-12 09:28 UTC] jorgen at zeklabs dot com
Thanks for the fast reply! However, I tried using the CVS, but it seems as if the fix isn't there and according to the change log (http://cvs.php.net/viewcvs.cgi/pear/Image_Graph/docs/ChangeLog) the last change was made 5 weeks ago.. =)
 [2006-04-12 09:36 UTC] nosey (Jesper Veggerby)
Whoops... I might have forgotten to actually commit it... sorry!
 [2006-04-12 10:39 UTC] jorgen at zeklabs dot com
Hehe, no problem. Which files are changed? And when will you commit the changes to the CVS? Many thanks for all the help!
 [2006-04-12 10:57 UTC] nosey (Jesper Veggerby)
It is more or less all Image/Graph/Plot/* files that have changed (actual code is swapping $this->_clip(false) and $this->_drawMarker() code lines). I'm afraid I won't be able to commit before friday.
 [2006-04-14 18:14 UTC] nosey (Jesper Veggerby)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.