Report new bug | New search | Development Roadmap Status: Open | Feedback | All

Bug #699 bz2 links send wrong Content-Type
Submitted: 2004-02-06 18:37 UTC
From: cipri Assigned: mj
Status: Closed Package: Web Site
PHP Version: Irrelevant OS: Windows 2000
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 33 - 13 = ?

 
 [2004-02-06 18:37 UTC] cipri
Description: ------------ Downloading the bz2 zipped version of the manual[1] sends a wrong HTTP header, which causes Internet Explorer to save the file as manual.tar.tar. This is the wrong header that is send during this process is the. Content-Type: application/x-tar Ths .bz2 file is not a tar file at all, but a bz2 file :) [1] http://pear.php.net/distributions/manual/pear_manual_en.tar.bz2 Reproduce code: --------------- Download http://pear.php.net/distributions/manual/pear_manual_en.tar.bz2 Expected result: ---------------- Have IE save the file as pear_manual_en.tar.bz2 Actual result: -------------- IE saves the file as pear_manual_en.tar.tar

Comments

 [2004-02-07 21:30 UTC] mj
Looks like application/octet-stream is the correct content type. I've changed the server configuration accordingly.