Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #6931 pear upgrade PEAR-alpha tries to upgrade to 1.4.0a12
Submitted: 2006-02-25 02:02 UTC
From: cellog Assigned: cellog
Status: Closed Package: PEAR (version 1.5.0)
PHP Version: Irrelevant OS: n/a
Roadmaps: (Not assigned)    
Subscription  


 [2006-02-25 02:02 UTC] cellog (Greg Beaver)
Description: ------------ cellog@localhost ~ $ pear up pear-alpha Failed to download pear/XML_RPC (recommended version 1.2.2), latest release is version 1.4.5, stability "stable", use "channel://pear.php.net/XML_RPC-1.4.5" to install Did not download optional dependencies: pear/PEAR_Frontend_Web, pear/PEAR_Frontend_Gtk, use --alldeps to download automatically pear/PEAR can optionally use package "pear/PEAR_Frontend_Web" (version >= 0.5.0) pear/PEAR can optionally use package "pear/PEAR_Frontend_Gtk" (version >= 0.4.0) downloading PEAR-1.4.0a12.tgz ... Starting to download PEAR-1.4.0a12.tgz (264,326 bytes) ......................................................done: 264,326 bytes ERROR: upgrade to a newer version (1.4.0a12 is not newer than 1.4.7) whooops!

Comments

 [2006-02-25 06:32 UTC] toggg
Why not a '>=' comparison instead of '==' in the removeInstalled() method of PEAR_Downloader_Package ? Does old versioning or PECL's one cause problem ? I suppose a downgrade should always need a --force , no ? I miss something ... --- /home/bertrand/pear/cvs/pear-core/PEAR/Downloader/Package.php 2006-01-23 20:23:56.000000000 +0100 +++ /usr/share/pear/PEAR/Downloader/Package.php 2006-02-25 07:21:47.000000000 +0100 @@ -370,7 +370,7 @@ // this does not need any pecl magic - we only remove exact matches if ($param->_installRegistry->packageExists($param->getPackage(), $param->getChannel())) { if (version_compare($param->_installRegistry->packageInfo($param->getPackage(), 'version', - $param->getChannel()), $param->getVersion(), '==')) {+ $param->getChannel()), $param->getVersion(), '>=')) { if (!isset($options['force'])) { $info = $param->getParsedPackage(); unset($info['version']);
 [2006-03-23 04:35 UTC] cellog (Greg Beaver)
this will be fixed in 1.5.0
 [2006-03-28 03:51 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.