Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #5939 Pear binary disappears after upgrade to 1.3.6
Submitted: 2005-11-11 17:00 UTC
From: normelton at gmail dot com Assigned:
Status: Duplicate Package: PEAR
PHP Version: 4.4.0 OS: RedHat EL
Roadmaps: (Not assigned)    
Subscription  


 [2005-11-11 17:00 UTC] normelton at gmail dot com
Description: ------------ Went to upgrade to Pear 1.3.6 after a recent PHP upgrade. Ran upgrade-all, and was told to install Auth_SASL in order to upgrade Net_SMTP. I cancelled the upgrade, installed Auth_SASL fine. Went back to upgrade-all. Everything proceeded as expected, but the Pear binary was gone. The upgrade message from Pear indicated that it worked as expected.

Comments

 [2005-11-11 17:07 UTC] cellog
Thank you for taking the time to report a problem with the package. Unfortunately you are not using a current version of the package -- the problem might already be fixed. Please download a new version from http://pear.php.net/packages.php If you are able to reproduce the bug with one of the latest versions, please change the package version on this bug report to the version you tested and change the status back to "Open". Again, thank you for your continued support of PEAR. PEAR 1.3.6 is very old, and the version you were upgrading from was god knows how old. 1.3.x has several critical bugs, and this is one of them that occasionally happens. The best plan of action is to re-install PEAR from go-pear.
 [2005-11-11 17:11 UTC] normelton at gmail dot com
Apologies... I was upgrading from 1.3.6 to 1.4.4. The binary happened during the upgrade to 1.4.4. I spoke with CPUnerd in #pear on freenode. He asked for the bug to be filed.
 [2005-11-11 17:15 UTC] cellog
HOw did you "cancel" the upgrade? Ctrl-C? Thanks, Greg
 [2005-11-11 17:24 UTC] normelton at gmail dot com
Honestly I don't remember. On the second box (which exhibited the same behavior), I didn't run upgrade-all first. I installed Auth_SASL, then did upgrade-all. If the original upgrade-all did not give me a prompt to quit, I would have Cntl-C'ed it. I don't believe it gave me the option to install it without quitting. Hope this helps, Norman
 [2005-11-11 17:24 UTC] cellog
this is actually a duplicate of http://pear.php.net/bugs/5906 Would you be so kind as to re-install PEAR 1.3.6, and try the upgrade again? I am pretty sure this is caused by a serious race condition bug in PEAR 1.3.x that was fixed by rewriting how it does file handling :/. In other words, to fix the bug you have to upgrade, but sometimes upgrading doesn't work - catch 22. However, if there is another cause, I would like to find a fix.
 [2005-11-11 17:26 UTC] cellog
quick note: this happened on two boxes? Please reply to bug 5906 Thanks :)