Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.9

Bug #565 pear run-tests broken
Submitted: 2004-01-13 18:26 UTC
From: yunosh Assigned:
Status: Bogus Package: PEAR
PHP Version: 4CVS-2004-01-13 (stable) OS:
Roadmaps: (Not assigned)    
Subscription  


 [2004-01-13 18:26 UTC] yunosh
Description: ------------ pear run-tests is currently broken because run-tests.php searches for the "pear" directory inside the specified directory.

Comments

 [2004-01-14 04:14 UTC] cellog
Can you verify that this does not work: $ pear run-tests /full/path/to/pear/tests
 [2004-01-14 10:00 UTC] yunosh
A further test showed a completely different problem. pear run-tests actually works fine (with absolute and relative paths) as long as the specified folder really contains tests. I accidentally ran the script on a "tests" folder that didn't contain .phpt files but other test scripts. So the tests were supposed to not work, but a more useful error message might help finding the cause.
 [2004-01-14 10:05 UTC] pajoye
Hello, This is not something up to us. I list a few issues we have to solve to help pe(ar|cl) packages tests here: http://marc.theaimsgroup.com/?l=php-dev&m=107348251720476&w=2 Once we solved them running tests should be a walk in the park (without the dogs ;) ). pierre
 [2004-01-14 14:47 UTC] cellog
Hi Jan, The source code for run-tests.php first checks to see if any of the things passed on the command-line contain .phpt files, and then it checks the hard-coded relative directories "tests" "pear" and "exts." If any of these directories don't exist, it gives an unhelpful error message saying that the directory doesn't exist. So, to sum up, this is a bug in the run-tests.php file, which is maintained by the php core folks, I would open a bug at bugs.php.net on this one. Thanks, Greg