Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.5

Bug #5513 PEAR 1.4 does not install non-pear.php.net packages
Submitted: 2005-09-25 08:32 UTC
From: sebastian at php dot net Assigned: cellog
Status: Closed Package: PEAR
PHP Version: 5_1 CVS-2005-09-25 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2005-09-25 08:32 UTC] sebastian at php dot net
Description: ------------ PEAR 1.4 does not install non-pear.php.net packages, for instance Creole, Propel, and Agavi. Actual result: -------------- sb@wopr-mobile ~ % pear install http://phing.info/pear/phing-current.tgz downloading phing-current.tgz ... Starting to download phing-current.tgz (361,527 bytes) .........................................................................done: 361,527 bytes Did not download dependencies: pear/VersionControl_SVN, pear/PhpDocumentor, pecl/Xdebug, pear/PEAR_PackageFileManager, use --alldeps or --onlyreqdeps to download automatically pear/phing can optionally use package "pear/VersionControl_SVN" (version >= 0.3.0alpha1) pear/phing can optionally use package "pear/PhpDocumentor" (version >= 1.3.0RC3) pear/phing can optionally use package "pear/Xdebug" (version >= 2.0.0beta2) pear/phing can optionally use package "pear/PEAR_PackageFileManager" (version >= 1.5.2) install ok: channel://pear.php.net/phing-2.1.1 sb@wopr-mobile ~ % pear install http://agavi.org/packages/agavi-current.tgz downloading agavi-current.tgz ... Starting to download agavi-current.tgz (66,645 bytes) .................done: 66,645 bytes Package "pear.php.net/agavi" dependency "pecl.php.net/phing" has no releases sb@wopr-mobile ~ % pear install http://propel.phpdb.org/pear/propel_generator-current.tgz downloading propel_generator-current.tgz ... Starting to download propel_generator-current.tgz (141,809 bytes) ..............................done: 141,809 bytes Package "pear.php.net/propel_generator" dependency "pecl.php.net/phing" has no releases

Comments

 [2005-09-25 09:26 UTC] toggg
I get the same with pear 1.4.1 (cvs) # pear list Installed packages, channel pear.php.net: ========================================= Package Version State Archive_Tar 1.3.1 stable Console_Getopt 1.2 stable PEAR 1.4.1 stable ... XML_RPC 1.4.1 stable phing 2.1.1 stable # pear install http://agavi.org/packages/agavi-current.tgz downloading agavi-current.tgz ... Starting to download agavi-current.tgz (66,645 bytes) .................done: 66,645 bytes Package "pear.php.net/agavi" dependency "pecl.php.net/phing" has no releases The dependency seems to be correct in agavi's package.xml: <?xml version="1.0" encoding="ISO-8859-1" ?> <!DOCTYPE package SYSTEM "http://pear.php.net/dtd/package-1.0"> <package version="1.0"> <name>agavi</name> .... <release> <version>0.9.0</version> <date>2005-06-08</date> <license>LGPL</license> <state>beta</state> <notes>See the CHANGELOG for full list of changes</notes> <deps> <dep type="pkg" rel="ge" version="2.0.0" optional="no">phing</dep> </deps> <filelist> ...
 [2005-09-25 13:01 UTC] pajoye
Thank you for taking the time to write to us, but this is not a bug. All of these packages use package-1.0 and have dependencies outside PEAR (or outside their respective servers). Ask them to release new versions and define channels dependencies if required.
 [2005-09-25 17:02 UTC] cellog
The problem here is that phing is already installed, and for some reason, it is not recognizing this fact and skipping the download check. This is very weird
 [2005-09-25 19:24 UTC] cellog
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.