Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.9

Bug #537 Funny error message
Submitted: 2004-01-07 16:38 UTC
From: yunosh Assigned:
Status: No Feedback Package: PEAR
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2004-01-07 16:38 UTC] yunosh
Description: ------------ pear install -a produces funny error messages Reproduce code: --------------- pear install -a mail_mime date auth_sasl net_url http_request file services_weather while preferred_state being set to stable Actual result: -------------- *After* downloading all packages: Release for Release for 'services_weather' dependency 'services_weather' 'XML_Serializer' has state 'beta', requires dependency 'SOAP' has 'stable' state 'beta', requires 'stable' install failed

Comments

 [2004-01-26 01:36 UTC] pajoye
This is related (partly) to #534, same remark. Delayed for the stable 1.3 release or 1.4. pierre
 [2004-04-03 06:09 UTC] cellog
Does this still occur with 1.3? I suspect the long term best way to fix this one is to implement all of the downloader code inside pearweb, and call something like package.getReleaseWithAllDeps($state = stable) package.getReleaseWithReqDeps($state = stable) These would do all the snaking through the dependency tree to determine the packages and versions needed, and simply return them in an array, or an error message. Greg