Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.9

Bug #5319 -c / -C configuration.file not effective
Submitted: 2005-09-07 11:58 UTC
From: toggg Assigned: toggg
Status: Closed Package: PEAR
PHP Version: 4.3.11 OS: FC3
Roadmaps: (Not assigned)    
Subscription  


 [2005-09-07 11:58 UTC] toggg
Description: ------------ The options -c or -C to pass a custom config file seems not to work. Passing a right config file does not change anything but the file name in config show. (tried with list and list-channels) Passing a wrong file (not a config) or even a non existing file has the same effect, only the name(s) (local/system) change. The expected error messages do not show, but here, seems raiseError() is working (I tried forcing it) Each time, the default config will be used.

Comments

 [2005-09-09 05:49 UTC] toggg
Checking back after renaming ~/.pearrc (so no local config): 1) Existing config file Actually, the only difference I had in this file was php_bin which seems not to be reflected. I imagine the actual system bin (but not the $PHP_PEAR_PHP_BIN) has precedence. I tried another with an alternate channel, which does not show up in list-channels. I imagine something is missing for this channel. However, I made a try changing verbose this time in the former config file, this change is taken into account. So, it seems to be allright in this case. 2) some non existing config file. Actually, I fall back to the php (from system but not from $PHP_PEAR_PHP_BIN) default setting, so that creates the file case I use S: $ pear -C blah -S $ cat blah #PEAR_Config 0.9 a:1:{s:10:"__channels";a:3:{s:12:"pecl.php.net";a:0:{}s:5:"__uri";a:0:{}s:14:"pear.upear.com";a:0:{}}} The problem is I don't get any warning or message meaning it's using default php setting, no existing config, and that a config will be / was created. Also, if I do then another command as: $ pear -C bleh list I get the result without any warning I'm defaulted to php settings. 3) Wrong file (I took anaconda configuration) (4.3.11 or 5.1-dev): # pear -vvvvv -C anaconda-ks.cfg config-show # No comment on console neither from me :)
 [2005-09-14 15:37 UTC] toggg
The bug also occurs without the -c or -C, by putting a wrong config file (corrupted) # pear config-show Configuration (channel pear.php.net): ===================================== Auto-discover new Channels auto_discover <not set> Default Channel default_channel pear.php.net HTTP Proxy Server Address http_proxy <not set> PEAR server [DEPRECATED] master_server pear.php.net Default Channel Mirror preferred_mirror pear.php.net Remote Configuration File remote_config <not set> PEAR executables directory bin_dir /usr/bin PEAR documentation directory doc_dir /usr/share/pear/doc PHP extension directory ext_dir /usr/lib/php4 PEAR directory php_dir /usr/share/pear PEAR Installer cache directory cache_dir /tmp/pear/cache PEAR data directory data_dir /usr/share/pear/data PHP CLI/CGI binary php_bin /usr/bin/php PEAR test directory test_dir /usr/share/pear/test Cache TimeToLive cache_ttl 3600 Preferred Package State preferred_state stable Unix file mask umask 22 Debug Log Level verbose 1 PEAR password (for password <not set> maintainers) Signature Handling Program sig_bin /usr/bin/gpg Signature Key Directory sig_keydir /etc/pearkeys Signature Key Id sig_keyid <not set> Package Signature Type sig_type gpg PEAR username (for username <not set> maintainers) User Configuration File Filename /root/.pearrc System Configuration File Filename /etc/pear.conf # ls /root/.pearrc ls: /root/.pearrc: No such file or directory # mv /etc/pear.conf /etc/pear.conf.ok # cp anaconda-ks.cfg /etc/pear.conf # pear config-show # (silently dies)
 [2005-09-14 19:46 UTC] toggg
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.