Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.13

Bug #5227 sed expression error during install
Submitted: 2005-08-29 08:19 UTC
From: pear at humbapa dot ch Assigned:
Status: Bogus Package: PEAR
PHP Version: 5.1.0 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2005-08-29 08:19 UTC] pear at humbapa dot ch
Description: ------------ when I try to build a PECL package I got an error message from sed during installation and building of the package fails. it doesn't matter which package I try. PHP 5.1.0 RC1 PEAR-1.3.6 GNU sed version 4.1.2 Debian etch (testing) with Kenel 2.6.12.5 thanks! Test script: --------------- pear install fileinfo Actual result: -------------- downloading Fileinfo-1.0.tgz ... Starting to download Fileinfo-1.0.tgz (5,566 bytes) .....done: 5,566 bytes 3 source files, building running: phpize Configuring for: PHP Api Version: 20041225 Zend Module Api No: 20050617 Zend Extension Api No: 220050617 sed: -e expression #1, char 0: no previous regular expression building in /var/tmp/pear-build-root/Fileinfo-1.0 running: /tmp/tmpl9S0KS/Fileinfo-1.0/configure running: make make: *** No targets specified and no makefile found. Stop. `make' failed

Comments

 [2005-08-31 16:27 UTC] cellog
you're going to need to ask pecl developers about this one. The fact that every single package fails means the problem is either on your end, or that you have a unique config that pecl devs did not take into account. please ask for help on pecl-dev and report back here after getting a response
 [2005-09-05 13:14 UTC] pear at humbapa dot ch
the error was because I built PHP with an empty prefix (--prefix=) rebuilding PHP with --prefix=/ solved the problem thanks to Jani Taskinen and Derick Rethans from PECL-DEV
 [2005-09-05 14:47 UTC] cellog
thanks