Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.9

Bug #5113 Package install error
Submitted: 2005-08-16 20:54 UTC
From: hello at vish dot info Assigned:
Status: Bogus Package: PEAR
PHP Version: 5.0.4 OS: BSD 4.11
Roadmaps: (Not assigned)    
Subscription  


 [2005-08-16 20:54 UTC] hello at vish dot info
Description: ------------ When trying to install the package ("pear install File") on two different machines and OSes, I get the following error: XML error: Undeclared entity warning at line 232

Comments

 [2005-08-17 08:41 UTC] tacker
I can confirm that for PHP 5.1
 [2005-08-17 11:03 UTC] andrew dot clarke at dkit dot ie
As the error message suggests, this is caused by an undeclared entity in the package.xml file. In line 37, I removed the Þ entity from the maintainers name and this solved the error.
 [2005-08-17 11:22 UTC] andrew dot clarke at dkit dot ie
As a follow up, I replaced the character entity Þ with the equivalent numeric entity Þ and this also solves the problem.
 [2005-08-17 13:07 UTC] dufuz
Seems this is a issue in the PEAR Installer, we already use Þ in the package.xml instead of Þ ... So the installer is doing the conversion.
 [2005-08-17 13:08 UTC] dufuz
Forgot to change the category
 [2005-08-17 15:45 UTC] cellog
this is a bug in the built-in PHP xml parser, which should recognize {-style entities and does not. There is a workaround in PEAR 1.4.x
 [2005-09-05 13:02 UTC] richard dot quadling at bandvulc dot co dot uk
How soon is this updated so that PEAR install FILE will work? If I use CVS to download PEAR (I am working on PHP documentation, but also like to see what is happening to PEAR), the package.xml file shows that File is stable at V1.2.2, but PEAR upgrade -f File will only install 1.2.1 I assume there is some mechanism to convert from CVS to PEAR? Regards, Richard.
 [2005-09-05 14:49 UTC] cellog
File 1.2.2 is not released yet. When it is released, it will be available