Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.8.0

Bug #4484 SVG output problem with fill and alignment attributes of text
Submitted: 2005-05-31 12:01 UTC
From: ruipraxis at hotmail dot com Assigned: nosey
Status: Closed Package: Image_Graph
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 50 + 22 = ?

 
 [2005-05-31 12:01 UTC] ruipraxis at hotmail dot com
Description: ------------ The "fill" attribute for text is incorrectly exported to svg files as "fill=rgb(...);" instead of "fill:rgb(...);". This causes problems in some viewers/editors, since color is not correctly rendered, and in some cases alignment is also incorrect, since it is placed after the fill attribute, and consequently ignored. This problem still exists in version 0.4.0 Reproduce code: --------------- The problem is in the "write()" function of the SVG driver (svg.php). Replacing "fill=" by "fill:" solves it.

Comments

 [2005-05-31 12:03 UTC] ruipraxis at hotmail dot com
(corrected the bug summary)
 [2005-06-03 19:06 UTC] pear dot nosey at veggerby dot dk
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.