Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.9.5

Bug #432 Imagick2.php generates warning imagick_free line 189
Submitted: 2003-12-15 22:08 UTC
From: rob at fireswamp dot biz Assigned: reywob
Status: Closed Package: Image_Transform
PHP Version: 4.3.4 OS: Redhat 8
Roadmaps: (Not assigned)    
Subscription  


 [2003-12-15 22:08 UTC] rob at fireswamp dot biz
Description: ------------ I'm guessing that Imagick2.php is fairly new... I found a bug, I think. Here is the error: imagick_free() expects parameter 1 to be resource, null given in /usr/local/php_01/lib/php/Image/Transform/Driver/Imagick2.php on line 189 I changed my file so that line 189 looks like this: imagick_free($this->imageHandle); Regards

Comments

 [2003-12-15 22:28 UTC] reywob at php dot net
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. Thanks for reporting!
 [2019-08-24 12:58 UTC] User who submitted this comment has not confirmed identity
If you submitted this note, check your email.If you do not have a message, click here to re-send
MANUAL CONFIRMATION IS NOT POSSIBLE.  Write a message to pear-dev@lists.php.net
to request the confirmation link.  All bugs/comments/patches associated with this

email address will be deleted within 48 hours if the account request is not confirmed!