Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.11.5

Bug #4193 sqlite dsn causes invalid _database
Submitted: 2005-04-20 22:18 UTC
From: randy at rcs-comp dot com Assigned: alan_k
Status: Closed Package: DB_DataObject
PHP Version: 5.0.2 OS:
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 19 + 22 = ?

 
 [2005-04-20 22:18 UTC] randy at rcs-comp dot com
Description: ------------ I was getting errors in the generator because the _database value was the full path of the sqlite database. That meant that line 236 of generator.php was creating a bade $file value. I changed line 107 to this: $t->_database = is_file($databasename) ? basename( $databasename) : $databasename; Not sure about other implications with this change. There is a similiar problem in dataObject.php in the _connect method when _database gets assigned a value. Reproduce code: --------------- Connect to a sqlite database and run the generator Expected result: ---------------- $file = c:/htdocs/ocfair2/configuration/classes/db/ocfair.db.ini Actual result: -------------- $file = c:/htdocs/ocfair2/configuration/classes/db/c:/htdocs/ocfair2/configuration/db/ocfair.db.ini

Comments

 [2005-06-04 02:59 UTC] alan_k
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. Finally!