Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.9

Bug #4060 pear upgrade Auth_HTTP fails with fatal error
Submitted: 2005-04-05 10:28 UTC
From: ants dot aasma at mig dot ee Assigned: cellog
Status: Closed Package: PEAR
PHP Version: 5.0.3 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2005-04-05 10:28 UTC] ants dot aasma at mig dot ee
Description: ------------ pear throws an fatal error trying to upgrade Auth_HTTP-2.1.4 to Auth_HTTP-2.1.6RC1. Pear version is 1.4.0a9. Reproduce code: --------------- pear upgrade Auth_HTTP Expected result: ---------------- upgrade ok Actual result: -------------- downloading Auth_HTTP-2.1.6RC1.tgz Starting to download Auth_HTTP-2.1.6RC1.tgz (9,294 bytes) .....done: 9,294 bytes Fatal error: Cannot use string offset as an array in /usr/lib/php/PEAR/Installer.php

Comments

 [2005-04-05 10:30 UTC] ants dot aasma at mig dot ee
Sorry, the line number was left off by mistake, the error is: Fatal error: Cannot use string offset as an array in /usr/lib/php/PEAR/Installer.php on line 454
 [2005-04-05 22:34 UTC] cellog
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. Thanks!