Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.2

Bug #369 GetOpt 1.1 breaks pearcmd
Submitted: 2003-12-06 11:50 UTC
From: l0nec0der at yahoo dot it Assigned: andrei
Status: Closed Package: Console_Getopt
PHP Version: 4.3.4 OS: Linux 2.2.19
Roadmaps: (Not assigned)    
Subscription  


 [2003-12-06 11:50 UTC] l0nec0der at yahoo dot it
Description: ------------ After upgrading to Console_GetOpt 1.1, (pear cli) pearcmd always runs in help mode, that is: # pear list pearcmd.php list [package] If invoked without parameters, this command lists the PEAR packages installed in your php_dir ({config php_dir)). With a parameter, it lists the files in that package. Reverting to 1.0 restores the original behaviour and lets me use the pear cli. --danny Reproduce code: --------------- # pear list Expected result: ---------------- # pear list Installed packages: =================== Package Version State Archive_Tar 1.1 stable Auth 1.2.2 stable .... Actual result: -------------- # pear list pearcmd.php list [package] If invoked without parameters, this command lists the PEAR packages installed in your php_dir ({config php_dir)). With a parameter, it lists the files in that package.

Comments

 [2003-12-06 16:28 UTC] andrei
Yes, the PEAR packages that depended on broken behavior need to be fixed. I haven't had a chance to go through and find all the places where that happens. Is there a taker for this?
 [2003-12-06 19:47 UTC] cellog
Hi, You should have released this as version 2.0 - it's a severe BC break, and renders PEAR completely unusable, requiring a manual overwrite to either GetOpt.php or Remote.php - there is no way to do it through the pear command once it is broken. I would recommend removing the release and renumbering it as 2.0, but you do what you want. Main thing is this is a critical bug, and suddenly forces us to do a release of PEAR - that's not so great, as there is no stable release of PEAR out there that works with 1.1. I sent a message to PEAR-Group recommending the release be removed as well until a workaround can be found. I'm happy to collaborate on this one, email me and we can set up some work time. Greg Greg
 [2003-12-06 21:41 UTC] cellog
I committed a patch to pearcmd.php that fixes this. It would be best to check with with the maintainers for PECL_Gen and System_ProcWatch to make sure their work is not broken by this change as well. I took the liberty of committing package-Console_Getopt.xml with the version number changed and the release notes updated, it's ready for release, Andrei will have to do the actual release since he's the lead. I added a dependency on PEAR 1.3b4, since that is the version in CVS. package-PEAR.xml also has a dependency on Console_Getopt 2.0 Greg
 [2003-12-06 22:00 UTC] cellog
Sigh... Just ran the test suites. The change to Console_Getopt breaks all of the installer and system tests, as well as the packager. :( Greg
 [2004-01-13 13:57 UTC] pajoye
Thank you for your bug report. This issue has already been fixed in the latest released version of the package, which you can download at http://pear.php.net/packages.php