Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.13

Bug #3526 Segmentation fault
Submitted: 2005-02-19 20:01 UTC
From: asdf at asdf dot com Assigned:
Status: Bogus Package: PEAR
PHP Version: 5.0.3 OS: Slackware Linux 10.0
Roadmaps: (Not assigned)    
Subscription  


 [2005-02-19 20:01 UTC] asdf at asdf dot com
Description: ------------ The commands config-show, config-get and config-set doesn't work as expected in PEAR 1.3.5. I always receive a segmentation fault when no layer is specified. The default layer is not chosen automatically. I use a self-compiled PHP 5.0.3 on a Slackware 10.0 box. The ./configure line is: './configure' '--with-apxs=/usr/sbin/apxs' '--enable-force-cgi-redirect' '--enable-fastcgi' '--enable-discard-path' '--prefix=/usr' '--with-config-file-path=/etc/apache' '--with-openssl' '--with-zlib=/usr' '--enable-bcmath' '--with-bz2' '--enable-calendar' '--enable-ctype' '--enable-dba=shared' '--with-gdbm' '--with-db3' '--enable-dio' '--enable-ftp' '--with-gd' '--enable-gd-native-ttf' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-gettext=shared,/usr' '--with-gmp=shared' '--enable-mbstring=all' '--with-mime-magic' '--with-mysql=shared,/usr/local/mysql' '--with-mysqli=/usr/local/mysql/bin/mysql_config' '--with-pspell=shared,/usr' '--enable-shmop' '--enable-soap' '--enable-sockets' '--with-regex=php' '--enable-sysvmsg' '--enable-sysvsem' '--enable-sysvshm' '--enable-wddx' '--enable-xml' '--with-xml=shared,/usr' '--with-xsl=/usr' '--enable-inline-optimization' '--enable-memory-limit' '--enable-shared' '--disable-static' '--enable-exif' '--disable-debug' I have the following PEAR packages installed: Installed packages: =================== Package Version State Archive_Tar 1.2 stable Benchmark 1.2.2 stable Config 1.10.4 stable Console_Getopt 1.2 stable DB 1.6.8 stable FSM 1.2.2 stable Log 1.8.7 stable PEAR 1.3.5 stable PHPUnit2 2.1.5 stable PhpDocumentor 1.3.0RC3 beta XML_Beautifier 1.1 stable XML_Parser 1.2.4 stable XML_RPC 1.1.0 stable XML_Util 1.1.1 stable xdebug 1.3.2 stable Reproduce code: --------------- pear config-get ext_dir Expected result: ---------------- /usr/lib/php/extensions/ Actual result: -------------- Segmentation fault

Comments

 [2005-02-19 20:46 UTC] cellog
Hi, A segmentation fault is by definition a bug in PHP, not in PEAR. However, this may be caused by an out-of-bounds array access or attempting to instantiate a non-existent object. If you can find the line that causes the seg fault, I might be able to help. Until then, this is considered a fault in your PHP. In other words, try the same thing in PHP 4 on your system, does it segfault? Thanks, Greg
 [2005-02-19 23:06 UTC] asdf at asdf dot com
Unfortunately I can't find out which line causes the error right now, because the only output is the "Segmentation fault", which makes it difficult to track. I haven't tested it with PHP 4, because I'm only running PHP 5 on my box. It worked with PEAR 1.3.4, so I thought it might be a PEAR problem. Sorry for that. Maybe I should have spent more time on searching before writing a bug report. Sorry again.
 [2005-02-19 23:42 UTC] cellog
To get more information, please re-compile PHP 5 --with-debug=on and follow the instructions at php.net to generate a backtrace (google it if you are not familiar with this procedure). Honestly, this bug probably exists in PEAR 1.3.4 as well - if you compare PEAR/Config.php in 1.3.4 to PEAR/Config.php in 1.3.5, they are identical. The only changes in PEAR 1.3.5 were to PEAR/Command/RunTest.php, and PEAR/Builder.php Greg
 [2005-02-20 12:02 UTC] pierre at dotgeek dot org
Cannot reproduce using either 5.0.3 or cvs HEAD. Please try with a recent cvs snapshots (snaps.php.net) or fetch the sources from cvs (php-src). You should try without xdebug as well. Does it work with HEAD or without xdebug? --Pierre
 [2005-02-20 15:07 UTC] asdf at asdf dot com
It is a problem with xdebug. When xdebug is disabled in the php.ini it works again.
 [2005-02-20 15:26 UTC] pierre at dotgeek dot org
Sorry, but your problem does not imply a bug in PEAR itself. For a list of more appropriate places to ask for help using PEAR, please visit http://pear.php.net/support/ as this bug system is not the appropriate forum for asking support questions. Thank you for your interest in PEAR. not a pear issue, neither PHP.