Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.15

Bug #3326 pear list-all results in memory exhausted
Submitted: 2005-01-29 18:01 UTC
From: tick at tick dot dk Assigned:
Status: Bogus Package: PEAR
PHP Version: 5.0.3 OS: FreeBSD 5.3
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 46 - 40 = ?

 
 [2005-01-29 18:01 UTC] tick at tick dot dk
Description: ------------ pear list Installed packages: =================== Package Version State Archive_Tar 1.2 stable Console_Getopt 1.2 stable DB 1.6.8 stable Net_CheckIP 1.1 stable PEAR 1.3.4 stable XML_RPC 1.2.0RC6 beta pear config-show Preferred Package State preferred_state stable OS: FreeBSD 5.3-RELEASE-p5 PHP-version: PHP 5.0.3 (cli) (built: Jan 20 2005 02:31:23) Copyright (c) 1997-2004 The PHP Group Zend Engine v2.0.3, Copyright (c) 1998-2004 Zend Technologies php -i | grep ini Configuration File (php.ini) Path => /usr/local/etc/php.ini grep memory /usr/local/etc/php.ini memory_limit = 32M But still: pear list-all Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 3735552 bytes) in XML/RPC.php(1203) : eval()'d code on line 760 Allowed memory size of 8388608 bytes exhausted (tried to allocate 0 bytes) Is this a bug in pear, or is it php ? php does read the ini-file because the output of php -i tells me that the memory limit is 32M which is what ive set in the ini-file.

Comments

 [2005-01-29 18:05 UTC] pierre at dotgeek dot org
Thank you for taking the time to write to us, but this is not a bug. Please read the php manual about memory limit.
 [2005-01-30 19:02 UTC] cellog
note: the reason you're experiencing the memory limit is a result of the -n switch in pear (do which pear to find it). Try removing this switch and see if it fixes the problem. -n causes php to ignore php.ini