Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.11.5

Bug #3058 typo in getLinkArray method
Submitted: 2004-12-30 09:23 UTC
From: xav at spotk dot net Assigned: alan_k
Status: Closed Package: DB_DataObject
PHP Version: Irrelevant OS: all
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 20 - 6 = ?

 
 [2004-12-30 09:23 UTC] xav at spotk dot net
Description: ------------ when calling the getLinkArray method, php throws an error because a typo in the method is_a() test is not done on the good variable. Reproduce code: --------------- --- DataObject.php 2004-10-05 18:49:59.000000000 +0200 +++ DataObject.php 2004-12-30 10:22:10.000000000 +0100 @@ -2569,7 +2569,7 @@ $c = $this->factory($table); - if (!is_a($obj,'DB_DataObject')) { + if (!is_a($c,'DB_DataObject')) { $this->raiseError( "getLinkArray:Could not find class for row $row, table $table", DB_DATAOBJECT_ERROR_INVALIDCONFIG

Comments

 [2004-12-30 09:29 UTC] xav at spotk dot net
I've already check that this bug is still in the latest cvs.
 [2005-01-22 03:30 UTC] alan_k
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.