Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.0.4

Request #2665 Translation2_Admin is not DB protable
Submitted: 2004-11-01 17:24 UTC
From: michael dot caplan at lechateau dot ca Assigned: quipo
Status: Duplicate Package: Translation2
PHP Version: Irrelevant OS: irrelevant
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 50 + 3 = ?

 
 [2004-11-01 17:24 UTC] michael dot caplan at lechateau dot ca
Description: ------------ I am not sure about other non-mysql databases, but definately on Oracle Translation2_Admin breaks in many places with the storage container used. For example, Translation2_Admin_Container_mdb2::_fetchTableNames() uses a mysql specific way o fetching table names. Also, all of the create / alter table queries are not protable either. I havn't had much experiance using the MDB/2 table manager, but it certainly would allow for much of the broken aspects in the storage container to be db portable. Is it possible to use the MDB/2 table management tools to do all your show, alter and create table SQL? Awesome library, btw. Michael

Comments

 [2004-11-01 17:55 UTC] quipo
This is a duplicate of bug #2543, which has been fixed in CVS. Please get an updated revision. http://cvs.php.net/co.php/pear/Translation2/