Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.5.5

Bug #2640 Problem with the example file 2.php
Submitted: 2004-10-28 15:35 UTC
From: james at FFFF dot ca Assigned: quipo
Status: Closed Package: Calendar
PHP Version: 4.3.9 OS: Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 40 + 7 = ?

 
 [2004-10-28 15:35 UTC] james at FFFF dot ca
Description: ------------ On a fresh install of Calendar 0.5.2, tried running the example 2.php. Got the following error: Warning: getengine(Calendar/Engine/UnixTs.php): failed to open stream: No such file or directory in /usr/local/php4/lib/php/Calendar/Calendar.php on line 80 I looked and I have a Calendar/Engine/UnixTS.php file, so there's probably just been a typo made somewhere, perhaps in Calendar.php? Either that, or the UnixTs.php file should be named UnixTS.php in the package.

Comments

 [2004-10-28 15:38 UTC] james at FFFF dot ca
After looking, it appears that the culprit is 2.php, and not the core Calendar files. Line 13 reads: define('CALENDAR_ENGINE','UnixTs'); This should be changed to define('CALENDAR_ENGINE','UnixTS'); to fix the problem.
 [2004-10-28 15:48 UTC] dufuz
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. Fixed in CVS, that I know since I spotted that bug my self and provided a patch :)
 [2004-10-28 16:05 UTC] quipo
This typo was fixed in CVS 5 weeks ago. Please always check the repository to see if the problem has already been solved. If the problem is still there, then open a bug report like you did in this case. Thanks for your help.