Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.4

Bug #2284 Fail to POST multiline COOKIE string
Submitted: 2004-09-06 07:24 UTC
From: balancer at balancer dot ru Assigned:
Status: Bogus Package: HTTP_Request
PHP Version: 4.3.9 OS: RedHat 7.3
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 39 - 10 = ?

 
 [2004-09-06 07:24 UTC] balancer at balancer dot ru
Description: ------------ Try to POST strings with newline and get like: Bad Request Your browser sent a request that this server could not understand. Request header field is missing ':' separator. Test! Apache/2.0.50 (Unix) PHP/4.3.2 Server at airfleet.ru Port 80

Comments

 [2004-09-06 07:50 UTC] balancer at balancer dot ru
It's bug in addCookie. I need use $req->addCookie($c, urlencode($v)); to post multiline cookie string.
 [2004-09-15 10:09 UTC] avb
It's not a bug, cookie spec states that specific encoding method for cookie content is *not* defined. If you are sure that the site you access actually uses urlencode() for cookie values, then add urlencode()'d cookies yourself. But bear in mind that some other site may use base64 for the encoding. See also bug #1080