Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.0

Bug #2210 line 258 has a typo
Submitted: 2004-08-24 21:23 UTC
From: tim at komta dot com Assigned: toby
Status: Closed Package: Net_FTP
PHP Version: 4.3.8 OS: Windows 2000 Server
Roadmaps: (Not assigned)    
Subscription  


 [2004-08-24 21:23 UTC] tim at komta dot com
Description: ------------ function pwd () { $res = @ftp_pwd($this->_handle); if (!$res) { return $this->raiseErrro("Could not determine the actual path.", 0); } else { return $res; } } Should be: function pwd () { $res = @ftp_pwd($this->_handle); if (!$res) { return $this->raiseError("Could not determine the actual path.", 0); } else { return $res; } } Reproduce code: --------------- Any call to NetFTP::pwd() that results in an error

Comments

 [2004-09-01 13:31 UTC] toby
This bug is fixed since ages. Please update your PEAR installation.
 [2004-09-01 15:04 UTC] tim at komta dot com
Actually, Toby, it hasn't been fixed at all. If you look at line 258 of version 1.2 (the current stable release) of Net_FTP, it is exactly as I've reported in the bug. In fact, I JUST downloaded it again to be sure, and there's the typo. Line 258 of the Net_FTP file. If you don't feel like fixing it, that's fine with me.
 [2004-09-06 18:11 UTC] toby
Please update to the recent 1.3, which is still beta, but will be stable in the near future.