Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.6.3

Bug #19925 missing agent complaint even if gpg version < 2.0
Submitted: 2013-04-30 22:29 UTC
From: pruss Assigned: alec
Status: Closed Package: Crypt_GPG (version 1.4.0b4)
PHP Version: 5.3.10 OS: Ubuntu 12.04
Roadmaps: (Not assigned)    
Subscription  


 [2013-04-30 22:29 UTC] pruss (Peter Russ)
Description: ------------ The check if agent is required should only be executed if gpg version >= 2 By now you always get an exception if gpg-agent is not installed

Comments

 [2013-06-29 12:02 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Feedback
We are unable to reproduce the bug as reported. Please provide a simple script (10 lines or less) or a link to an external script that can be used to reproduce the bug. If you can provide the script, feel free to add it to this bug and change the status back to "Open". Thank you for your interest in PEAR.
 [2016-01-28 10:44 UTC] alec (Aleksander Machniak)
-Status: Feedback +Status: Verified
The Crypt_GPG_Engine code confirms that. Lines 594-606 should be executed only for gnupg 2.x.
 [2016-04-15 06:56 UTC] alec (Aleksander Machniak)
-Status: Verified +Status: Closed -Assigned To: +Assigned To: alec
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.