Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #19650 Cannot install PHPUnit 3.6.12
Submitted: 2012-10-13 09:13 UTC
From: sebastian Assigned:
Status: Open Package: PEAR (version 1.9.4)
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  


 [2012-10-13 09:13 UTC] sebastian (Sebastian Bergmann)
Description: ------------ At the time of writing, PHPUnit 3.7 is the current version of PHPUnit. PHPUnit 3.6 shares dependencies with PHPUnit 3.7 but is incompatible with newer versions of some of these dependencies. This fact is expressed using <max> elements in the package.xml. Trying to install PHPUnit 3.6.12 leads to "Duplicate package" errors for these dependencies. Test script: --------------- pear install http://pear.phpunit.de/get/PHPUnit-3.6.12.tgz Expected result: ---------------- No errors Actual result: -------------- ? ~ pear install http://pear.phpunit.de/get/PHPUnit-3.6.12.tgz downloading PHPUnit-3.6.12.tgz ... Starting to download PHPUnit-3.6.12.tgz (120,240 bytes) ..........................done: 120,240 bytes Did not download optional dependencies: phpunit/PHP_Invoker, use --alldeps to download automatically Duplicate package channel://pear.phpunit.de/Text_Template-1.1.2 found Duplicate package channel://pear.phpunit.de/Text_Template-1.1.3 found install failed

Comments