Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.1.4

Bug #19587 PHP backend fails when encoding type is set to UTF-8 instead of utf-8
Submitted: 2012-08-28 01:26 UTC
From: gauthierm Assigned: doconnor
Status: Closed Package: XML_RPC2 (version 1.1.1)
PHP Version: 5.4.4 OS:
Roadmaps: (Not assigned)    
Subscription  


 [2012-08-28 01:26 UTC] gauthierm (Michael Gauthier)
Description: ------------ XML_RPC2 backend throws an exception when encoding type is set to UTF-8, UTF8 or utf8: XML_RPC2_Backend_Php does not support any encoding other than utf-8, due to a simplexml limitation Expected result: ---------------- XML_RPC2 should allow encoding types UTF-8, UTF8 or utf8 and translate them to utf-8

Comments

 [2012-08-30 07:44 UTC] doconnor (Daniel O'Connor)
Got reproduce code?
 [2012-08-30 07:45 UTC] doconnor (Daniel O'Connor)
Nevermind, I see it on the CI box :)
 [2012-08-30 07:47 UTC] doconnor (Daniel O'Connor)
Marking as unmaintained - last release was a QA release, other bugs (docco links for example) are unresponded to for over a month.
 [2012-08-30 07:51 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Closed -Assigned To: +Assigned To: doconnor
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.