Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #18782 class tree generation mistake
Submitted: 2011-09-03 06:10 UTC
From: drunkenstranger Assigned: ashnazg
Status: Closed Package: PhpDocumentor (version SVN)
PHP Version: 5.2.12 OS:
Roadmaps: 1.4.4    
Subscription  


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 19 + 16 = ?

 
 [2011-09-03 06:10 UTC] drunkenstranger (Drunken Stranger)
Description: ------------ When class tree generated if one of #root child have her own childs, class tree list losts inheritance level. Test script: --------------- <?php /** Test file for MyPackage2 class tree * @package MyPackage2 */ /** @package MyPackage1 */ class MyClass1 {} /** @package MyPackage2 */ class MyClass2 extends MyClass1 {} /** @package MyPackage2 */ class MyClass3 extends MyClass2 {} /** @package MyPackage2 */ class MyClass4 extends MyClass3 {} /** @package MyPackage2 */ class MyClass5 extends MyClass2 {} ?> Expected result: ---------------- MyClass1 (Different package) MyClass2 MyClass3 MyClass4 MyClass5 Actual result: -------------- MyClass1 (Different package) MyClass2 MyClass3 MyClass4 MyClass5

Comments

 [2011-09-03 06:20 UTC] drunkenstranger (Drunken Stranger)
 [2011-09-24 02:26 UTC] ashnazg (Chuck Burgess)
-Status: Open +Status: Verified -Assigned To: +Assigned To: ashnazg -Roadmap Versions: +Roadmap Versions: 1.4.4
 [2011-09-24 02:57 UTC] ashnazg (Chuck Burgess)
Verified bug behavior on phpDocumentor 1.4.3 using PHP 5.3.8, 5.2.17, and 4.4.9. Interestingly, it's only visible in MyPackage2's Class List view... the Class List for Package1 shows the correct hierarchy layout of "MyClass5 is child of MyClass2".
 [2011-09-24 04:24 UTC] ashnazg (Chuck Burgess)
Verified bug exists in current SVN version of phpDocumentor too, on PHPs 5.3.8, 5.2.17, and 4.4.9.
 [2011-09-24 04:42 UTC] ashnazg (Chuck Burgess)
Patch does seem to fix test case across all three PHP versions (just looking at HTML:frames:default converter at this point). Need to run some larger regression tests to verify no unintended side effects.
 [2011-09-24 07:25 UTC] ashnazg (Chuck Burgess)
I see no regressions when running the patched phpDocumentor (just HTML:frames:default converter) against the PhpDocumentor codebase itself, compared with svn version of phpDocumentor against the same target codebase. Next step is to apply patches against all converter files, build a larger test case (with many packages and many class levels), and run the patched code using all output converters.
 [2011-09-24 10:32 UTC] ashnazg (Chuck Burgess)
Built a more complicated test case, implemented patches in all converter files, ran all output converters. Bug behavior fixed in all cases. Fix committed to SVN.
 [2011-09-24 10:32 UTC] ashnazg (Chuck Burgess)
-Status: Verified +Status: Closed