Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.13

Bug #18639 regression: installing xdebug fails most likely due to another fix
Submitted: 2011-06-30 23:34 UTC
From: till Assigned: dufuz
Status: Closed Package: PEAR (version 1.9.3)
PHP Version: 5.3.1 OS:
Roadmaps: (Not assigned)    
Subscription  


 [2011-06-30 23:34 UTC] till (Till Klampaeckel)
Description: ------------ http://svn.php.net/viewvc/pear/pear- core/trunk/PEAR/Builder.php? r1=311616&r2=311615&pathrev=311616 Someone on #pear mentioned that this fixed something for xhprof (their screwed up file layout), but now xdebug fails to install. Test script: --------------- till@till-laptop:~/workspaces/Mail_Queue/trunk/tests$ sudo pear upgrade-all Will upgrade channel://pear.zfcampus.org/zf Will upgrade channel://pecl.php.net/xdebug geometria-lab/rediska dependency package "zfcampus/zf" downloaded version 1.11.7 is not the recommended version 1, but may be compatible, use --force to install zfcampus/ZF cannot be installed, conflicts with installed packages downloading xdebug-2.1.1.tgz ... Starting to download xdebug-2.1.1.tgz (303,198 bytes) ............done: 303,198 bytes 66 source files, building running: phpize Cannot find config.m4. Make sure that you run '/usr/bin/phpize' in the top level source directory of the module ERROR: `phpize' failed Expected result: ---------------- No error. Actual result: -------------- Error.

Comments

 [2011-07-02 08:04 UTC] dufuz (Helgi Þormar Þorbjörnsson)
That fix actually has nothing to do with it... I checked already. Still haven't found the specific cause.
 [2011-07-02 23:39 UTC] till (Till Klampaeckel)
I can install various extensions with the previous release, but not with this. List of failures include xdebug, apm, etc.. I do have a question about 'testing' patches. How do you do it? Is there a way to run 'pear' from within the pear-core directory? Or how do you go about it?
 [2011-07-03 00:04 UTC] till (Till Klampaeckel)
-Status: Open +Status: Analyzed
Ok, I think I figured it out: pear package package-PEAR.xml pear install <the-created-package> So btw, I have a patch which works. I can now install all extensions again: https://gist.github.com/1061465 Changelog: - introduced $tempDir as a temporary variable - compare the file's basename - break the loop only when 'config.m4' was found - slightly refactoring of that loop I didn't want to commit it, but I can if you give me the go-ahead.
 [2011-07-04 01:55 UTC] dufuz (Helgi Þormar Þorbjörnsson)
package-PEAR.xml is v1, use package2.xml when you are doing the testing. They are both kept up to date (for now), just safer. I will look at your patch and see if I can use it. Thanks
 [2011-07-04 02:04 UTC] dufuz (Helgi Þormar Þorbjörnsson)
The fix you are proposing does not fix the main problem but that's a different bug perhaps, it's a problem with v1 packages.
 [2011-07-04 02:48 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Analyzed +Status: Closed -Assigned To: +Assigned To: dufuz
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. I committed my version of the patch (a bit simpler). Can you try trunk?
 [2011-07-04 18:43 UTC] till (Till Klampaeckel)
Fix works for me.