Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #17690 Patch: deprecation of set_magic_quotes_runtime
Submitted: 2010-08-11 00:38 UTC
From: olleolleolle Assigned:
Status: Wont fix Package: PhpDocumentor (version SVN)
PHP Version: 5.3.3 OS:
Roadmaps: (Not assigned)    
Subscription  


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 41 + 7 = ?

 
 [2010-08-11 00:38 UTC] olleolleolle (Olle Jonsson)
Description: ------------ Not using set_magic_quotes_runtime would be nice. Let's log a message instead to the error log. Inspired by http://test.pear.php.net/unit-test- results/deprecated.txt Here is a patch: https://gist.github.com/8525ade0ba31171bf618

Comments

 [2010-08-11 00:38 UTC] olleolleolle (Olle Jonsson)
 [2010-08-22 12:16 UTC] olleolleolle (Olle Jonsson)
-Summary: deprecation of set_magic_quotes_runtime +Summary: Patch: deprecation of set_magic_quotes_runtime
 [2010-08-24 07:05 UTC] doconnor (Daniel O'Connor)
-Assigned To: +Assigned To: olleolleolle
Can you re-work it at all to raise errors in a PHP4 friendly way?
 [2010-08-24 07:09 UTC] doconnor (Daniel O'Connor)
This will have the same impact as Bug #17774 - put it to the community too.
 [2011-10-15 03:39 UTC] ashnazg (Chuck Burgess)
Given that I'm not yet sure PhpDocumentor will be fully "upgraded" to handle all of PHP 5.3's new stuff/quirks, this may not get changed. Presumably this usage is in the code based on PHP4'ish needs, and therefore would need to remain.
 [2012-01-13 08:24 UTC] ashnazg (Chuck Burgess)
-Status: Assigned +Status: Open -Roadmap Versions: +Roadmap Versions: 2.0.0a1
 [2012-03-24 22:55 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Wont fix -Roadmap Versions: 2.0.0a1 +Roadmap Versions:
PHPDocumentor2 ... Wooo..