Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.13

Bug #17463 Regression: On Windows, svntag
Submitted: 2010-06-03 06:07 UTC
From: doconnor Assigned: dufuz
Status: Closed Package: PEAR (version 1.9.1)
PHP Version: 5.2.12 OS:
Roadmaps: (Not assigned)    
Subscription  


 [2010-06-03 06:07 UTC] doconnor (Daniel O'Connor)
Description: ------------ Since 1.9.0, it looks like pear svntag is kaput :( Test script: --------------- C:\work\pear\packages\Net_IDNA\trunk>pear svntag package.xml Expected result: ---------------- Package svntags. Actual result: -------------- C:\work\pear\packages\Net_IDNA\trunk>pear package Analyzing Net/IDNA.php Package Net_IDNA-0.8.0.tgz done Tag the released code with `pear svntag package.xml' (or set the SVN tag Net_IDNA-0.8.0 by hand) C:\work\pear\packages\Net_IDNA\trunk>pear svntag package.xml Can not locate the tags directory at Ctags C:\work\pear\packages\Net_IDNA\trunk>pear upgrade -f PEAR-1.9.0 downloading PEAR-1.9.0.tgz ... Starting to download PEAR-1.9.0.tgz (291,634 bytes) .............................................................done: 291,634 bytes upgrade ok: channel://pear.php.net/PEAR-1.9.0 PEAR: Optional feature webinstaller available (PEAR's web-based installer) PEAR: Optional feature gtkinstaller available (PEAR's PHP-GTK-based installer) PEAR: Optional feature gtk2installer available (PEAR's PHP-GTK2-based installer) PEAR: To install optional features use "pear install pear/PEAR#featurename" 'HO' is not recognized as an internal or external command, operable program or batch file. C:\php\.\php.exe C:\work\pear\packages\Net_IDNA\trunk>pear version PEAR Version: 1.9.0 PHP Version: 5.2.13 Zend Engine Version: 2.2.0 Running on: Windows NT ADL-A51239 5.1 build 2600 C:\work\pear\packages\Net_IDNA\trunk>pear svntag package.xml Validation: 0 error(s), 0 warning(s) + svn mkdir Ctags/Net_IDNA-0.8.0 svn copy --parents "Net/IDNA.php" "Ctags/Net_IDNA-0.8.0\Net/IDNA.php" svn copy --parents "test/test_php4.php" "Ctags/Net_IDNA-0.8.0\test/test_php4.php" svn copy --parents "test/test_php5.php" "Ctags/Net_IDNA-0.8.0\test/test_php5.php" A C:\work\pear\packages\Net_IDNA\trunk\Ctags A C:\work\pear\packages\Net_IDNA\trunk\Ctags\Net_IDNA-0.8.0 A C:\work\pear\packages\Net_IDNA\trunk\Ctags\Net_IDNA-0.8.0\Net A Ctags\Net_IDNA-0.8.0\Net\IDNA.php A C:\work\pear\packages\Net_IDNA\trunk\Ctags\Net_IDNA-0.8.0\test A Ctags\Net_IDNA-0.8.0\test\test_php4.php A Ctags\Net_IDNA-0.8.0\test\test_php5.php + svn ci -m "Tagging the 0.8.0 release" Ctags/Net_IDNA-0.8.0 C:\work\pear\packages\Net_IDNA\trunk>

Comments

 [2010-07-24 17:38 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Assigned To: +Assigned To: dufuz
So did you do this with 1.9.0 or 1.9.1 that is marked on the report? 1.9.1 had a fix to svntag.
 [2010-08-07 21:14 UTC] dufuz (Helgi Þormar Þorbjörnsson)
*bump*
 [2010-08-08 16:32 UTC] doconnor (Daniel O'Connor)
Good question; looks like I did this on my work computer. I'll check in a day or two, or worksforme this if you like.
 [2010-08-08 16:34 UTC] doconnor (Daniel O'Connor)
Actually, this would be 1.9.1 - downgrading to 1.9.0 "fixed" it.
 [2010-09-07 04:09 UTC] dufuz (Helgi Þormar Þorbjörnsson)
Did you look at the path? C:\work\pear\packages\Net_IDNA\trunk\Ctags\Net_IDNA-0.8.0\Net It's adding Ctags under trunk, first off, Ctags sounds wrong and second tags shouldn't be under trunk. Are you sure there is a problem here? Or at least, are you sure that 1.9.0 actually worked?
 [2010-09-07 04:15 UTC] doconnor (Daniel O'Connor)
Yeah, I'm sure it works under 1.9.0 and not 1.9.1. It'll be some kind of stupidity with windows paths and escaping. Looking at the installed version, doSvnTag() is doing stuff like: $dir = dirname($packageFile); $dir = substr($dir, strrpos($dir, '/') + 1); and if (in_array($svntag . '/', explode("\n", $out))) { instead of PATH_SEPERATOR
 [2010-09-07 04:45 UTC] doconnor (Daniel O'Connor)
 [2010-09-11 17:19 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Summary: Regression: svntag +Summary: Regression: On Windows, svntag -Status: Assigned +Status: Closed
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.