Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.0

Bug #16136 init.d stop does not work
Submitted: 2009-04-22 04:46 UTC
From: garrettmoon Assigned: kvz
Status: Closed Package: System_Daemon (version 0.7.0)
PHP Version: 5.2.9 OS: Debian
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 15 - 14 = ?

 
 [2009-04-22 04:46 UTC] garrettmoon (Garrett Moon)
Description: ------------ This appears to have to do with PIDFILE being set incorrectly in the init.d autogenerated script on DEBIAN. PIDFILE is not replaced with appPidLocation. A fix is adding the line: "/var/run/\$NAME.pid" => '{PROPERTIES.appPidLocation}', in the $autoRunTemplateReplace array in Debian.php I'm not sure if there are other issues as well as RedHat.php uses the variable pidFile which I don't find anywhere.

Comments

 [2009-04-25 15:24 UTC] kvz (Kevin van Zonneveld)
-Status: Open +Status: Closed -Assigned To: +Assigned To: kvz
You are right. The skeleton file should use the full appPidLocation instead of a fixed /var/run/<NAME>.pid, which is no longer the default pid location for System_Daemon based daemons. I fixed the issue in SVN 11 days ago as it was reported to me by Igor Moiseev as well. http://trac.phpjs.org/projects/system_daemon/browser/trunk/System/Daemon/OS/Debian.php I will soon release a new version.