Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.4

Bug #159 Net_Sieve hangs when sasl doesn't report back plain as a login method
Submitted: 2003-10-27 12:43 UTC
From: tarjei at nu dot no Assigned: damian
Status: Closed Package: Net_Sieve
PHP Version: 4.3.1 OS: SuSE 8.2
Roadmaps: (Not assigned)    
Subscription  


 [2003-10-27 12:43 UTC] tarjei at nu dot no
Description: ------------ Hi, If you try to use Net_Sieve with a Cyrus Sieveserver that doesn't support login, Sieve will hang without any errormessages. Reproduce code: --------------- #!/usr/bin/php -f <? require_once('Net/Sieve.php'); $host = 'localhost'; // add username here $username = ''; $password = ''; $port = 2000; /* this will hang if the server doesn't support plain */ $sieve = new Net_Sieve($username, $password, $host,$port,'PLAIN'); if (PEAR::isError($sieve)) { } ?>

Comments

 [2003-12-01 09:24 UTC] yunosh
Problems start at line 279: if ($logintype == 'PLAIN' AND in_array('PLAIN', $this->_capability['sasl'])) { where $this->_capability might look like: array(2) { ["implementation"]=> string(23) "Cyrus timsieved v2.1.15" ["extensions"]=> array(9) { [0]=> string(8) "fileinto" [1]=> string(6) "reject" [2]=> string(8) "envelope" [3]=> string(8) "vacation" [4]=> string(9) "imapflags" [5]=> string(6) "notify" [6]=> string(10) "subaddress" [7]=> string(10) "relational" [8]=> string(5) "regex" } }
 [2004-01-31 20:15 UTC] damian at php dot net
Thank you for this bug report. To properly diagnose the problem, we need a backtrace to see what is happening behind the scenes. To find out how to generate a backtrace, please read http://bugs.php.net/bugs-generating-backtrace.php Once you have generated a backtrace, please submit it to this bug report and change the status back to "Open". Thank you for helping us make PEAR better. The new auth infrastructure sould correct this
 [2004-01-31 20:16 UTC] damian
In version 0.9 sould be corrected
 [2004-03-01 02:30 UTC] damian at php dot net
Thank you for your bug report. This issue has already been fixed in the latest released version of the package, which you can download at http://pear.php.net/packages.php Version 0.9.1 of Net_Sieve solves this bug