Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #14201 templatebase not working as intended
Submitted: 2008-06-20 08:20 UTC
From: jbwdevries Assigned: ashnazg
Status: Closed Package: PhpDocumentor (version 1.4.2)
PHP Version: 5.2.6 OS: Windows XP 32bit
Roadmaps: 1.4.4    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 32 - 6 = ?

 
 [2008-06-20 08:20 UTC] jbwdevries (Johan Vries(de))
Description: ------------ Steps to reproduce: 1) Copy the converters directory to a place outside the PEAR directory 2) Copy the templates for HandS to HandS2 in the new directory 3) Run phpdoc on a project using phpdoc --output "HTML:Smarty:HandS2" --templatebase DIRECTORY where DIRECTORY is the directory that contains the converters directory 4) It will complain: ERROR: template directory "/path/to/pear/data/PhpDocumentor/phpDocumentor/Converters/HTML/Smarty/templates/HandS2/" does not exist while it should look in the templateBase directory Initial investigation of cause: In Convertor.inc is Converter::setTemplateBase called by Converter::setTemplateDir. But that function never receives the templateBase parameter, it takes an educated guess base on the installation directory. Possible solution: Pass the templateBase directory to the Convertor class. Expected result: ---------------- phpDocumentor would take the templates (*.tpl) files from that directory. Actual result: -------------- phpDocumentor takes the Converor from the templateBase directory, but the templates from the PEAR data directory.

Comments

 [2008-12-30 19:34 UTC] stevehsu2 (Steven Hsu)
Think this has the same root cause as 13653
 [2009-07-21 21:33 UTC] ashnazg (Chuck Burgess)
-Roadmap Versions: +Roadmap Versions: 1.4.3
 [2009-10-12 00:39 UTC] ashnazg (Chuck Burgess)
-Status: Open +Status: Verified -Assigned To: +Assigned To: ashnazg
 [2009-10-12 01:35 UTC] ashnazg (Chuck Burgess)
-Status: Verified +Status: Closed
Committed fix to SVN... thanks for the hints, Steven.