Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.4

Bug #1369 Empty last line breaks Image_Color Version 1.0.0 if used with header()
Submitted: 2004-05-08 22:20 UTC
From: tb at despammed dot com Assigned:
Status: Bogus Package: Image_Color
PHP Version: 4.3.3 OS: Linux / Debian
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 46 - 32 = ?

 
 [2004-05-08 22:20 UTC] tb at despammed dot com
Description: ------------ after a fresh install (using "pear install Image_Color") the file Color.php contains an empty last line which effectively breaks the package for use with the header()-function. I found this while using Image_Graph, which is then unable to use the header() function and barfs. Reproduce code: --------------- require_once("Image/Color.php"); Expected result: ---------------- The code should not give output, but it outputs an empty line. Actual result: -------------- An empty line.

Comments

 [2004-05-08 22:24 UTC] tb at despammed dot com
made title more appropriate -- it doesnt break the package *all the time*, but only under special use.
 [2004-05-09 05:43 UTC] sebastian
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely to be the same. Because of this, we hope you add your comments to the existing bug instead. Thank you for your interest in PEAR. Duplicate of #1332.