Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.15

Bug #13484 pear package brings up warnings
Submitted: 2008-03-24 21:53 UTC
From: till Assigned: dufuz
Status: Closed Package: PEAR (version 1.7.1)
PHP Version: 5.2.5 OS: FreeBSD
Roadmaps: 1.7.2    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 40 - 36 = ?

 
 [2008-03-24 21:53 UTC] till (Till Klampaeckel)
Description: ------------ Warning: Invalid argument supplied for foreach() in PEAR/PackageFile/v2.php on line 1650 PHP Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/PackageFile/v2.php on line 1650 Warning: Invalid argument supplied for foreach() in PEAR/PackageFile/v2.php on line 1650 PHP Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/PackageFile/v2.php on line 1650 Warning: Invalid argument supplied for foreach() in PEAR/PackageFile/v2.php on line 1650 PHP Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/PackageFile/v2.php on line 1650 Warning: Invalid argument supplied for foreach() in PEAR/PackageFile/v2.php on line 1650 PHP Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/PackageFile/v2.php on line 1650 Warning: Invalid argument supplied for foreach() in PEAR/PackageFile/v2.php on line 1650 PHP Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/PackageFile/v2.php on line 1650 Warning: Invalid argument supplied for foreach() in PEAR/PackageFile/v2.php on line 1650 PHP Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/PackageFile/v2.php on line 1650 Warning: Invalid argument supplied for foreach() in PEAR/PackageFile/v2.php on line 1650 PHP Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/PackageFile/v2.php on line 1650 Warning: Invalid argument supplied for foreach() in PEAR/PackageFile/v2.php on line 1650 PHP Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/PackageFile/v2.php on line 1650 Warning: Invalid argument supplied for foreach() in PEAR/PackageFile/v2.php on line 1650 PHP Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/PackageFile/v2.php on line 1650 Warning: Invalid argument supplied for foreach() in PEAR/PackageFile/v2.php on line 1650 PHP Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/PackageFile/v2.php on line 1650 Warning: Invalid argument supplied for foreach() in PEAR/PackageFile/v2.php on line 1650 PHP Warning: Invalid argument supplied for foreach() in /usr/local/share/pear/PEAR/PackageFile/v2.php on line 1650 Test script: --------------- I'm just fixing up DB_DO2, I can give you a link to SVN so you can check it out and "pear package" yourself, if needed. Expected result: ---------------- No warnings. ;-)

Comments

 [2008-03-24 22:04 UTC] till (Till Klampaeckel)
 [2008-03-28 18:33 UTC] dufuz (Helgi Þormar Þorbjörnsson)
The problem is this part: <optional> </optional> No point in keeping it around since it's empty, that's what the installer was choking on but I'll fix it so it shouldn't get the warning regardless of an empty optional/required or not.
 [2008-03-28 18:36 UTC] dufuz (Helgi Þormar Þorbjörnsson)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2008-03-29 19:44 UTC] till (Till Klampaeckel)
Thanks, Helgi!