Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.9

Bug #1249 wrong preferred state warning using -f option
Submitted: 2004-04-21 08:46 UTC
From: jeroen at terena dot nl Assigned: pajoye
Status: Closed Package: PEAR
PHP Version: Irrelevant OS: linux
Roadmaps: (Not assigned)    
Subscription  


 [2004-04-21 08:46 UTC] jeroen at terena dot nl
Description: ------------ I upgraded to HTTP_Download (but this affects any package I think) using -f because my preferred state is stable and I got a message saying this package is Alpha. But it's not Alpha, it's Beta. At least that's what http://pear.php.net/package/HTTP_Download says. pear upgrade -f HTTP_Download Warning: HTTP_Download is state 'alpha' which is less stable than state 'stable' downloading HTTP_Download-0.6.2.tgz ... Starting to download HTTP_Download-0.6.2.tgz (6,236 bytes) .....done: 6,236 bytes upgrade ok: HTTP_Download 0.6.2 I have PEAR-1.3.1 installed. Reproduce code: --------------- pear upgrade -f HTTP_Download (with preferred state set to stable) Expected result: ---------------- warning that HTTP_Download is Beta not Stable Actual result: -------------- warning that HTTP_Download is Alpha

Comments

 [2004-04-21 10:33 UTC] neufeind
See Cipri's mail for first details http://marc.theaimsgroup.com/?l=pear-dev&m=108246920600982&w=2 It says: "This seems to be a bug in PEAR.php in the code on lines 459 to 477. If the force option is applied, the code loops trough all the released versions, ending with the last one(state: alpha) before noticing it can't find exactly what you want. After the loop, the $inf var is still used, which still contains the info on the last package :)"
 [2004-05-16 15:27 UTC] paj at pearfr dot org
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.