Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.10

Bug #12468 Wrong message for invalid command
Submitted: 2007-11-17 14:11 UTC
From: felipensp Assigned: dufuz
Status: Closed Package: PEAR
PHP Version: Irrelevant OS:
Roadmaps: 1.7.0    
Subscription  
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes. If this is not your bug, you can add a comment by following this link. If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
2007-11-17 21:02 UTC
Package:
Bug Type:
Summary:
From: felipensp at gmail dot com
New email:
PHP Version: Package Version: OS:

 

 [2007-11-17 14:11 UTC] felipensp at gmail dot com (Felipe Pena)
Description: ------------ Wrong message for invalid command. Reproduce code: --------------- felipe@pena:~$ pecl foo Expected result: ---------------- Command 'foo' is not valid, try 'pecl help' Actual result: -------------- Command 'foo' is not valid, try 'pear help'

Comments

 [2007-11-17 15:37 UTC] msaraujo at php dot net
Thank you for taking the time to write to us, but this is not a bug. Hello, What is the proper message for an invalid command?
 [2007-11-17 15:40 UTC] cweiske at php dot net
I think it should read "pecl" not "pear"
 [2007-11-17 16:14 UTC] philip at roshambo dot org
This is actually a pear bug, here's a patch: Index: pear-core/scripts/pearcmd.php =================================================================== RCS file: /repository/pear-core/scripts/pearcmd.php,v retrieving revision 1.37 diff -u -r1.37 pearcmd.php --- pear-core/scripts/pearcmd.php 8 Jan 2007 05:14:01 -0000 1.37 +++ pear-core/scripts/pearcmd.php 17 Nov 2007 14:23:38 -0000 @@ -394,7 +394,7 @@ return "$progname $command [options] $help[0]\n$help[1]"; } } - return "Command '$command' is not valid, try 'pear help'"; + return "Command '$command' is not valid, try '$progname help'"; }
 [2007-11-17 16:23 UTC] cweiske (Christian Weiske)
re-assigning to pear
 [2007-11-17 21:02 UTC] dufuz (Helgi Þormar Þorbjörnsson)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.