Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.9

Bug #1157 go-pear.php "'pear' command is not currently in your path" even when it is
Submitted: 2004-04-07 17:07 UTC
From: danielc Assigned: pajoye
Status: Duplicate Package: PEAR
PHP Version: 5CVS-2004-04-07 (dev) OS: Windows
Roadmaps: (Not assigned)    
Subscription  


 [2004-04-07 17:07 UTC] danielc
Description: ------------ The pear command is in my %path% but go-pear.php is saying it's not. Perhaps the program is doing a case sensitive comparison, which under *nix is reasonable, but under Windows isn't. Reproduce code: --------------- php go-pear.php Expected result: ---------------- No warning about path. Actual result: -------------- ** The 'pear' command is not currently in your PATH, so you need to ** use 'c:\progra~1\pear\pear.bat' until you have added ** 'c:\progra~1\pear' to your PATH environment variable.

Comments

 [2004-05-16 14:23 UTC] paj at pearfr dot org
How is called your pear command? and what is the full path? We checked through the PATH folders if any of *.exe, *.bat, *.com, or *.cmd exist in a custom which command. The test is done with file_exists which takes of case sensitive problem on each platform. -- Pierre
 [2004-05-16 14:35 UTC] danielc
Called command like this: C:\PROGRA~1\php>go-pear PATH: [... snip ...];C:\PROGRA~1\php;[... snip ...]
 [2004-05-17 14:30 UTC] danielc
I think I've pinned down what's going on here. go-pear.php is thinking the just installed pear.bat is an old one, so renames it pear.bat_old, therefore, OF COURSE pear.bat isn't in my path! But, the hangup is, I'm performing a fresh install. Though, I had PEAR installed, I renamed the old dir, so no old files were really there. It seems the check for old pear files is happening after the install rather than before. I added some debugging echos into go-pear.php and here's what came out... ... snip ... Current include path : .;C:\php5\pear Configured directory : c:\progra~1\pear\pear Currently used php.ini (guess) : Press Enter to continue: >>>> LOOKING FOR pear >>>> FOUND C:\PROGRA~1\pear\pear.bat ** WARNING! Backed up old pear to C:\PROGRA~1\pear\pear.bat_old The 'pear' command is now at your service at c:\progra~1\pear\pear.bat >>>> LOOKING FOR pear ** The 'pear' command is not currently in your PATH, so you need to ** use 'c:\progra~1\pear\pear.bat' until you have added ** 'c:\progra~1\pear' to your PATH environment variable. ... snip ...
 [2004-05-17 14:35 UTC] danielc
Therefore, this bug is caused by Bug #1156.
 [2004-05-18 01:36 UTC] test at analysis dot users dot panix dot com
Pardon me. Testing.
 [2004-05-18 01:37 UTC] danielc
Finish testing.