Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.9

Bug #1156 go-pear.php fresh install "Backed up old pear"
Submitted: 2004-04-07 17:03 UTC
From: danielc Assigned: pajoye
Status: Closed Package: PEAR
PHP Version: 5CVS-2004-04-07 (dev) OS: Windows
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 42 - 33 = ?

 
 [2004-04-07 17:03 UTC] danielc
Description: ------------ Did a fresh install of PEAR using the go-pear.php found in a PHP 5 snapshot from last night on my Win32 machine. To make this really fresh, I renamed my old PEAR directory, though I did not blow away the windows registry entries. Upon completion of the process, I got this warning: ** WARNING! Backed up old pear to C:\PROGRA~1\pear\pear.bat_old Even though there was no old file really there. Plus, it was renamed the new file to pear.bat_old, leaving me with no pear.bat file.

Comments

 [2004-05-31 17:07 UTC] pierre at dotgeek dot org
Please try with a cvs version of go-pear (pearweb/public_html/go-pear) --Pierre
 [2004-06-01 15:46 UTC] danielc
Found the problem. It's due to case sensitivity. Here's a patch: http://www.analysisandsolutions.com/pear/gopear.win32.case.diff This also solves bug #1157: pear is in the path, but go-pear says it's not.
 [2004-06-01 16:09 UTC] cellog
this patch isn't quite right - you set $pearcmd to '' on non-windows platforms. It should be $pear_cmd = $bin_dir . DIRECTORY_SEPARATOR . 'pear'; - $pear_cmd .= WINDOWS?'.bat':''; + $pear_cmd = WINDOWS ? strtolower($pear_cmd) . '.bat' : $pearcmd; instead of $pear_cmd = $bin_dir . DIRECTORY_SEPARATOR . 'pear'; - $pear_cmd .= WINDOWS?'.bat':''; + $pear_cmd = WINDOWS ? strtolower($pear_cmd).'.bat' : '';
 [2004-06-01 16:16 UTC] danielc
Good catch, Greg. Thanks.
 [2004-06-01 16:36 UTC] danielc
Just to be clear... The patch file has been corrected.
 [2004-06-06 22:46 UTC] pierre at dotgeek dot org
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/packages.php
 [2005-03-31 15:22 UTC] Makemoneyy at yahoo dot com
I have installed current relese version of PHP5.0.3 however bug #1157 seems to still appear in my code... And i pretty new to php coding... please explain in detail how to use the patch...?
 [2006-12-01 17:32 UTC] chris at crgs dot co dot uk (Christopher Hill)
I am still seeing this problem on a new install of PHP 5.2.0. Under Windows if you do a 'clean' Pear install you end up with pear.bat_old which has to be renamed to pear.bat in order to get it working. Can someone have another look at this please?